[phpMyAdmin Developers] Time for 4.7.6?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[phpMyAdmin Developers] Time for 4.7.6?

Isaac Bennetch
Hi team,

Do you think it's time for 4.7.6? With the US holiday last week, I
haven't yet performed the release which normally would have been a few
days ago, but looking at ChangeLog there aren't a lot of changes. Here
are the changes:

- issue #13517 Fixed check all interaction with filtering
- issue #13803 Add SJIS-win to default list of allowed charsets
- issue #13436 Improve detection that MySQL server needs SSL connection
- issue #13038 Support JSON datatype on MariaDB 10.2.7 and newer
- issue #13824 Fixed constructing ALTER query with AFTER

Isaac

_______________________________________________
Developers mailing list
[hidden email]
https://lists.phpmyadmin.net/mailman/listinfo/developers
Reply | Threaded
Open this post in threaded view
|

Re: [phpMyAdmin Developers] Time for 4.7.6?

Michal Čihař
Hi

On Mon, 2017-11-27 at 15:12 -0500, Isaac Bennetch wrote:
> Do you think it's time for 4.7.6? With the US holiday last week, I
> haven't yet performed the release which normally would have been a
> few
> days ago, but looking at ChangeLog there aren't a lot of changes.

Yesterday I'd say it's time for 4.7.6, but today I'd wait for phpseclib
issue to clarify.

--
        Michal Čihař | https://cihar.com/ | https://weblate.org/

_______________________________________________
Developers mailing list
[hidden email]
https://lists.phpmyadmin.net/mailman/listinfo/developers

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [phpMyAdmin Developers] Time for 4.7.6?

Isaac Bennetch
On Wed, Nov 29, 2017 at 3:57 AM, Michal Čihař <[hidden email]> wrote:

> Hi
>
> On Mon, 2017-11-27 at 15:12 -0500, Isaac Bennetch wrote:
>> Do you think it's time for 4.7.6? With the US holiday last week, I
>> haven't yet performed the release which normally would have been a
>> few
>> days ago, but looking at ChangeLog there aren't a lot of changes.
>
> Yesterday I'd say it's time for 4.7.6, but today I'd wait for phpseclib
> issue to clarify.

Looks like 2.0.9 will fix that issue, so I can work on the release a
bit later today.
Just to clarify, I should build with Composer running PHP5, so that
the dependencies work for all users; is that correct?

Thanks

>
> --
>         Michal Čihař | https://cihar.com/ | https://weblate.org/
>
> _______________________________________________
> Developers mailing list
> [hidden email]
> https://lists.phpmyadmin.net/mailman/listinfo/developers
>

_______________________________________________
Developers mailing list
[hidden email]
https://lists.phpmyadmin.net/mailman/listinfo/developers
Reply | Threaded
Open this post in threaded view
|

Re: [phpMyAdmin Developers] Time for 4.7.6?

Michal Čihař
Hi

On Wed, 2017-11-29 at 08:34 -0500, Isaac Bennetch wrote:
> Looks like 2.0.9 will fix that issue, so I can work on the release a
> bit later today.

Yes, it's fixed in 2.0.9 and composer.json is updated in both master
and QA_4_7.

> Just to clarify, I should build with Composer running PHP5, so that
> the dependencies work for all users; is that correct?

You can instead configure composer to act like it would be running on
PHP 5.5 by:

composer config -g platform.php 5.5

That way it doesn't matter which PHP version you use, so it's probably
safer in long term :-).

--
        Michal Čihař | https://cihar.com/ | https://weblate.org/

_______________________________________________
Developers mailing list
[hidden email]
https://lists.phpmyadmin.net/mailman/listinfo/developers

signature.asc (849 bytes) Download Attachment